Wednesday, December 19, 2012

Age of Mythology for Mac, Network Address Wrongness

Well, I've lost a chunk of my life to a really stupid problem with Age of Mythology for the Macintosh.

My family and I like to play network games on the home LAN around the holidays. We have several old favorites, most of them were bought when they were old, too. We save dollars that way, plus we can buy enough for everyone's system without going broke.

One of those is Age of Mythology, from MacSoft.

Unfortunately, it tries to be intelligent with its network configuration. To simplify things, ya know? And it simplifies things to the point where you can't configure which network it uses, or any other network settings.

We have it on four systems. Two worked just fine right away. The third we saw was choosing its wired ethernet address over its wireless address. Unplug the wired network and hey, presto, it works. Number four, my own system, didn't respond to that.

I poked around through config files and tried editing them by hand, scanned the file system (find does more than Spotlight), and so on. All four games had been installed the same. They'd patched up to version 2.01, which fixes problems with an "out of sync" error in versions of OS X of Leopard and above. I looked on the internet, went many pages deep into various Google searches, and spelunked my computer's file system, hoping that I wouldn't wreck anything.

Nothing was working for me.

Finally, after chewing at it for literally hours, I stumbled into it.

Mamas Don't Let Your Babies Grow Up to Share Internet
Under System Preferences, there's a setting for Internet Sharing. I have it turned on, so that my beige G3 can reach the internet though my iMac's wireless connection.

Age of Mythology hates me for it.

Once I turned Internet Sharing off, and unplugged the wired Ethernet, I was able to connect to the other three computers with the game.


No comments:

Post a Comment